summaryrefslogtreecommitdiffstats
path: root/cpukit/libblock/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2003-03-27 15:20:19 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2003-03-27 15:20:19 +0000
commit8bdf1d6ac29f3126b98e9b519b627d91cc35d082 (patch)
treef5232ac2c19f6ecc4fcf68264720d13b8ff15a9e /cpukit/libblock/Makefile.am
parent2003-03-27 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-8bdf1d6ac29f3126b98e9b519b627d91cc35d082.tar.bz2
2003-03-27 Joel Sherrill <joel@OARcorp.com>
* ChangeLog, Makefile.am: ATA code depends upon libchip/ide which is not allowed in the cpukit source code since it must be buildable independent of any BSP. These files were moved to libchip/ide. * include/rtems/ata.h, include/rtems/ata_internal.h: Removed.
Diffstat (limited to 'cpukit/libblock/Makefile.am')
-rw-r--r--cpukit/libblock/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/cpukit/libblock/Makefile.am b/cpukit/libblock/Makefile.am
index c8f5e949d4..411f1b2561 100644
--- a/cpukit/libblock/Makefile.am
+++ b/cpukit/libblock/Makefile.am
@@ -19,7 +19,6 @@ $(PROJECT_INCLUDE)/rtems:
include_rtems_HEADERS = \
include/rtems/bdbuf.h include/rtems/blkdev.h \
include/rtems/diskdevs.h include/rtems/ramdisk.h \
- include/rtems/ata.h include/rtems/ata_internal.h \
include/rtems/ide_part_table.h
PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems \
@@ -28,7 +27,7 @@ PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems \
LIB = ${ARCH}/libblock.a
C_FILES = src/bdbuf.c src/blkdev.c src/diskdevs.c src/ramdisk.c\
- src/ata.c src/ide_part_table.c
+ src/ide_part_table.c
OBJS = $(C_FILES:src/%.c=${ARCH}/%.$(OBJEXT))