summaryrefslogtreecommitdiffstats
path: root/testsuites/support/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/support/Makefile.am')
-rw-r--r--testsuites/support/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/testsuites/support/Makefile.am b/testsuites/support/Makefile.am
index f6b07afa2e..2e92bce1d2 100644
--- a/testsuites/support/Makefile.am
+++ b/testsuites/support/Makefile.am
@@ -13,6 +13,7 @@ PREINSTALL_FILES =
$(PROJECT_INCLUDE)/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)
@: > $(PROJECT_INCLUDE)/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/$(dirstamp)
$(PROJECT_INCLUDE)/tmacros.h: include/tmacros.h $(PROJECT_INCLUDE)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/tmacros.h
@@ -22,4 +23,6 @@ $(PROJECT_INCLUDE)/buffer_test_io.h: include/buffer_test_io.h $(PROJECT_INCLUDE)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/buffer_test_io.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/buffer_test_io.h
+CLEANFILES = $(PREINSTALL_FILES)
+
include $(top_srcdir)/../automake/local.am