summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/unix/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/score/cpu/unix/Makefile.am')
-rw-r--r--cpukit/score/cpu/unix/Makefile.am12
1 files changed, 5 insertions, 7 deletions
diff --git a/cpukit/score/cpu/unix/Makefile.am b/cpukit/score/cpu/unix/Makefile.am
index 753c677a81..c3ddc3ce11 100644
--- a/cpukit/score/cpu/unix/Makefile.am
+++ b/cpukit/score/cpu/unix/Makefile.am
@@ -34,16 +34,14 @@ PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems/score \
C_FILES = cpu.c
C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-REL = $(ARCH)/rtems-cpu.rel
+LIB = $(ARCH)/libscorecpu.a
-rtems_cpu_rel_OBJECTS = $(C_O_FILES)
+libscorecpu_a_OBJECTS = $(C_O_FILES)
-$(REL): $(rtems_cpu_rel_OBJECTS)
- $(make-rel)
+$(LIB): $(libscorecpu_a_OBJECTS)
+ $(make-library)
-all-local: $(ARCH) $(rtems_cpu_rel_OBJECTS) $(REL)
-
-.PRECIOUS: $(REL)
+all-local: $(ARCH) $(LIB)
EXTRA_DIST = cpu.c