summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/unix/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-07-26 13:32:13 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-07-26 13:32:13 +0000
commita85d8ecbb71c5f1950407b6adfe0fabba3cb523a (patch)
treee5f6fb33d3132b0cb1e26cdb64a29b39397d0ca3 /cpukit/score/cpu/unix/Makefile.am
parent2002-07-26 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-a85d8ecbb71c5f1950407b6adfe0fabba3cb523a.tar.bz2
2002-07-26 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Build libscorecpu.a instead of rtems-cpu.rel.
Diffstat (limited to 'cpukit/score/cpu/unix/Makefile.am')
-rw-r--r--cpukit/score/cpu/unix/Makefile.am12
1 files changed, 5 insertions, 7 deletions
diff --git a/cpukit/score/cpu/unix/Makefile.am b/cpukit/score/cpu/unix/Makefile.am
index 753c677a81..c3ddc3ce11 100644
--- a/cpukit/score/cpu/unix/Makefile.am
+++ b/cpukit/score/cpu/unix/Makefile.am
@@ -34,16 +34,14 @@ PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems/score \
C_FILES = cpu.c
C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-REL = $(ARCH)/rtems-cpu.rel
+LIB = $(ARCH)/libscorecpu.a
-rtems_cpu_rel_OBJECTS = $(C_O_FILES)
+libscorecpu_a_OBJECTS = $(C_O_FILES)
-$(REL): $(rtems_cpu_rel_OBJECTS)
- $(make-rel)
+$(LIB): $(libscorecpu_a_OBJECTS)
+ $(make-library)
-all-local: $(ARCH) $(rtems_cpu_rel_OBJECTS) $(REL)
-
-.PRECIOUS: $(REL)
+all-local: $(ARCH) $(LIB)
EXTRA_DIST = cpu.c