summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/powerpc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/score/cpu/powerpc/Makefile.am')
-rw-r--r--cpukit/score/cpu/powerpc/Makefile.am34
1 files changed, 33 insertions, 1 deletions
diff --git a/cpukit/score/cpu/powerpc/Makefile.am b/cpukit/score/cpu/powerpc/Makefile.am
index 2d953e706b..d19d12eeca 100644
--- a/cpukit/score/cpu/powerpc/Makefile.am
+++ b/cpukit/score/cpu/powerpc/Makefile.am
@@ -25,10 +25,42 @@ PREINSTALL_FILES = $(PROJECT_INCLUDE) \
$(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
include_rtems_scoredir = $(includedir)/rtems/score
-include_rtems_score_HEADERS = rtems/score/ppc.h rtems/score/types.h
+include_rtems_score_HEADERS = \
+ rtems/score/ppc.h \
+ rtems/score/types.h
+include_rtems_score_HEADERS += rtems/score/cpu.h
+
+$(PROJECT_INCLUDE)/rtems/old-exceptions:
+ $(mkinstalldirs) $@
+
+include_rtems_old_exceptionsdir = $(includedir)/rtems/old-exceptions
+include_rtems_old_exceptions_HEADERS = rtems/old-exceptions/cpu.h
+
+$(PROJECT_INCLUDE)/rtems/new-exceptions:
+ $(mkinstalldirs) $@
+
+include_rtems_new_exceptionsdir = $(includedir)/rtems/new-exceptions
+include_rtems_new_exceptions_HEADERS = rtems/new-exceptions/cpu.h
+
+
+$(PROJECT_INCLUDE)/rtems/powerpc:
+ $(mkinstalldirs) $@
+
+include_rtems_powerpcdir = $(includedir)/rtems/powerpc
+include_rtems_powerpc_HEADERS = rtems/powerpc/registers.h
+
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score \
$(include_rtems_score_HEADERS:%.h=$(PROJECT_INCLUDE)/%.h)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/old-exceptions \
+ $(include_rtems_old_exceptions_HEADERS:%.h=$(PROJECT_INCLUDE)/%.h)
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/new-exceptions \
+ $(include_rtems_new_exceptions_HEADERS:%.h=$(PROJECT_INCLUDE)/%.h)
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/powerpc \
+ $(include_rtems_powerpc_HEADERS:%.h=$(PROJECT_INCLUDE)/%.h)
+
# $(PROJECT_RELEASE)/lib$(MULTISUBDIR)/rtems$(LIB_VARIANT).o: $(ARCH)/rtems.o
# $(INSTALL_DATA) $< $@