summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/powerpc/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-04-18 20:54:19 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-04-18 20:54:19 +0000
commit4a0d87ee09cb3c1d3cb98d2907a046a463777c3e (patch)
treee709cfe0c0073b139395d60fc3fe15d57c5204f5 /cpukit/score/cpu/powerpc/Makefile.am
parent2002-04-20 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-4a0d87ee09cb3c1d3cb98d2907a046a463777c3e.tar.bz2
2002-04-18 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* asm.h: Include cpuopts.h instead of targopts.h. * rtems/new-exceptions/cpu.h: Relocated from libbsp/powerpc/support/new_exception_processing/rtems/score/cpu.h * rtems/old-exceptions/cpu.h: Relocated from c/src/lib/libbsp/powerpc/support/old_exception_processing/rtems/score/cpu.h * rtems/powerpc/registers.h: Relocated and renamed from libcpu/powerpc/shared/include/cpu.h. * rtems/score/cpu.h: New. * Makefile.am: Reflect changes above.
Diffstat (limited to 'cpukit/score/cpu/powerpc/Makefile.am')
-rw-r--r--cpukit/score/cpu/powerpc/Makefile.am34
1 files changed, 33 insertions, 1 deletions
diff --git a/cpukit/score/cpu/powerpc/Makefile.am b/cpukit/score/cpu/powerpc/Makefile.am
index 2d953e706b..d19d12eeca 100644
--- a/cpukit/score/cpu/powerpc/Makefile.am
+++ b/cpukit/score/cpu/powerpc/Makefile.am
@@ -25,10 +25,42 @@ PREINSTALL_FILES = $(PROJECT_INCLUDE) \
$(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
include_rtems_scoredir = $(includedir)/rtems/score
-include_rtems_score_HEADERS = rtems/score/ppc.h rtems/score/types.h
+include_rtems_score_HEADERS = \
+ rtems/score/ppc.h \
+ rtems/score/types.h
+include_rtems_score_HEADERS += rtems/score/cpu.h
+
+$(PROJECT_INCLUDE)/rtems/old-exceptions:
+ $(mkinstalldirs) $@
+
+include_rtems_old_exceptionsdir = $(includedir)/rtems/old-exceptions
+include_rtems_old_exceptions_HEADERS = rtems/old-exceptions/cpu.h
+
+$(PROJECT_INCLUDE)/rtems/new-exceptions:
+ $(mkinstalldirs) $@
+
+include_rtems_new_exceptionsdir = $(includedir)/rtems/new-exceptions
+include_rtems_new_exceptions_HEADERS = rtems/new-exceptions/cpu.h
+
+
+$(PROJECT_INCLUDE)/rtems/powerpc:
+ $(mkinstalldirs) $@
+
+include_rtems_powerpcdir = $(includedir)/rtems/powerpc
+include_rtems_powerpc_HEADERS = rtems/powerpc/registers.h
+
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score \
$(include_rtems_score_HEADERS:%.h=$(PROJECT_INCLUDE)/%.h)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/old-exceptions \
+ $(include_rtems_old_exceptions_HEADERS:%.h=$(PROJECT_INCLUDE)/%.h)
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/new-exceptions \
+ $(include_rtems_new_exceptions_HEADERS:%.h=$(PROJECT_INCLUDE)/%.h)
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/powerpc \
+ $(include_rtems_powerpc_HEADERS:%.h=$(PROJECT_INCLUDE)/%.h)
+
# $(PROJECT_RELEASE)/lib$(MULTISUBDIR)/rtems$(LIB_VARIANT).o: $(ARCH)/rtems.o
# $(INSTALL_DATA) $< $@