summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 2b16964ac1..00580824a0 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -136,6 +136,9 @@ AC_CHECK_HEADERS([tar.h errno.h sched.h sys/cdefs.h sys/queue.h],,
AS_IF([test -n "$rtems_missing_header"],
AC_MSG_ERROR([Missing required header $rtems_missing_header])])
+AC_CHECK_HEADERS([semaphore.h])
+AM_CONDITIONAL([HAVE_SEMAPHORE_H],[test x"$ac_cv_header_semaphore_h" = x"yes"])
+
## error out if libc doesn't provide stdint.h
AS_IF([test x"${ac_cv_header_stdint_h}" != xyes],
[AC_MSG_ERROR([Required header stdint.h not found])])