summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2015-03-09 13:18:35 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2015-03-10 08:56:06 +0100
commitf244bfc5f8a938d61567b0d78eeac35cd757f0d9 (patch)
tree90c8fde2bfc2f4ca72b648c9b74fe8e20a793833 /cpukit/configure.ac
parentlibcsupport: Delete superfluous _gettimeofday() (diff)
downloadrtems-f244bfc5f8a938d61567b0d78eeac35cd757f0d9.tar.bz2
posix: Install <semaphore.h> only if not provided
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 2b16964ac1..00580824a0 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -136,6 +136,9 @@ AC_CHECK_HEADERS([tar.h errno.h sched.h sys/cdefs.h sys/queue.h],,
AS_IF([test -n "$rtems_missing_header"],
AC_MSG_ERROR([Missing required header $rtems_missing_header])])
+AC_CHECK_HEADERS([semaphore.h])
+AM_CONDITIONAL([HAVE_SEMAPHORE_H],[test x"$ac_cv_header_semaphore_h" = x"yes"])
+
## error out if libc doesn't provide stdint.h
AS_IF([test x"${ac_cv_header_stdint_h}" != xyes],
[AC_MSG_ERROR([Required header stdint.h not found])])