summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index f6385bf83b..51063a1b0c 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -88,10 +88,14 @@ AC_CHECK_HEADER([tar.h])
AC_CHECK_HEADER([sys/errno.h],[],
[AC_MSG_ERROR([Missing required header sys/errno.h])])
-## if using newlib, force using stdint.h
-AS_IF([test x"${RTEMS_USE_NEWLIB}" = xyes],
+## if libc provides stdint.h, use it.
+AS_IF([test x"${ac_cv_header_stdint_h}" = xyes],
[RTEMS_USES_STDINT_H=yes],
-[RTEMS_USES_STDINT_H=$ac_cv_header_stdint_h])
+[RTEMS_USES_STDINT_H=no])
+
+## error out if libc doesn't at least provide inttypes.h
+AS_IF([test x"${ac_cv_header_inttypes_h}" != xyes],
+[AC_MSG_ERROR([Required header inttypes.h not found])])
AS_IF([test x"${RTEMS_USE_NEWLIB}" = xyes],
[RTEMS_USES_TAR_H=yes],