summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2006-11-14 09:14:58 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2006-11-14 09:14:58 +0000
commitd62a2e0100ba533fee3e7d7a12f90ed9d95736e8 (patch)
tree77b16a1f92a6830af33a0486792121f1d49af087 /cpukit/configure.ac
parent2006-11-14 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-d62a2e0100ba533fee3e7d7a12f90ed9d95736e8.tar.bz2
2006-11-14 Ralf Corsépius <ralf.corsepius@rtems.org>
* configure.ac: Require inttypes.h, check for stdint.h.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index f6385bf83b..51063a1b0c 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -88,10 +88,14 @@ AC_CHECK_HEADER([tar.h])
AC_CHECK_HEADER([sys/errno.h],[],
[AC_MSG_ERROR([Missing required header sys/errno.h])])
-## if using newlib, force using stdint.h
-AS_IF([test x"${RTEMS_USE_NEWLIB}" = xyes],
+## if libc provides stdint.h, use it.
+AS_IF([test x"${ac_cv_header_stdint_h}" = xyes],
[RTEMS_USES_STDINT_H=yes],
-[RTEMS_USES_STDINT_H=$ac_cv_header_stdint_h])
+[RTEMS_USES_STDINT_H=no])
+
+## error out if libc doesn't at least provide inttypes.h
+AS_IF([test x"${ac_cv_header_inttypes_h}" != xyes],
+[AC_MSG_ERROR([Required header inttypes.h not found])])
AS_IF([test x"${RTEMS_USE_NEWLIB}" = xyes],
[RTEMS_USES_TAR_H=yes],