summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 6d377d26fd..32c4fcb8b2 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -232,6 +232,12 @@ RTEMS_CPUOPT([__RTEMS_DO_NOT_INLINE_CORE_MUTEX_SEIZE__],
[1],
[disable inlining _Thread_Enable_dispatch])
+## This improves both the size and coverage analysis.
+RTEMS_CPUOPT([__RTEMS_DO_NOT_UNROLL_THREADQ_ENQUEUE_PRIORITY__],
+ [test x"${RTEMS_DO_NOT_UNROLL_THREADQ_ENQUEUE_PRIORITY}" = x"1"],
+ [1],
+ [disable inlining _Thread_queue_Enqueue_priority])
+
## This gives the same behavior as 4.8 and older
RTEMS_CPUOPT([__RTEMS_STRICT_ORDER_MUTEX__],
[test x"${ENABLE_STRICT_ORDER_MUTEX}" = x"1"],