summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-10 20:32:48 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-10 20:32:48 +0000
commit3a0827287dc2c2328e953fead2b883501053c444 (patch)
treeb531e6db204a3acaa8d7ab7c434b90aed1790b5c /cpukit/configure.ac
parent2009-07-10 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-3a0827287dc2c2328e953fead2b883501053c444.tar.bz2
2009-07-10 Joel Sherrill <joel.sherrill@OARcorp.com>
* configure.ac, score/src/threadqenqueuepriority.c: Add RTEMS_DO_NOT_UNROLL_THREADQ_ENQUEUE_PRIORITY to give user ability to disable the loop in _Thread_queue_Enqueue_priority from being unrolled. This reduces code size and makes coverage analysis easier.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 6d377d26fd..32c4fcb8b2 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -232,6 +232,12 @@ RTEMS_CPUOPT([__RTEMS_DO_NOT_INLINE_CORE_MUTEX_SEIZE__],
[1],
[disable inlining _Thread_Enable_dispatch])
+## This improves both the size and coverage analysis.
+RTEMS_CPUOPT([__RTEMS_DO_NOT_UNROLL_THREADQ_ENQUEUE_PRIORITY__],
+ [test x"${RTEMS_DO_NOT_UNROLL_THREADQ_ENQUEUE_PRIORITY}" = x"1"],
+ [1],
+ [disable inlining _Thread_queue_Enqueue_priority])
+
## This gives the same behavior as 4.8 and older
RTEMS_CPUOPT([__RTEMS_STRICT_ORDER_MUTEX__],
[test x"${ENABLE_STRICT_ORDER_MUTEX}" = x"1"],