summaryrefslogtreecommitdiffstats
path: root/c/src/optman/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/optman/Makefile.am')
-rw-r--r--c/src/optman/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/c/src/optman/Makefile.am b/c/src/optman/Makefile.am
index 3a40a6b6db..df38993204 100644
--- a/c/src/optman/Makefile.am
+++ b/c/src/optman/Makefile.am
@@ -18,11 +18,11 @@ C_O_FILES += $(rtems_C_FILES:rtems/%.c=${ARCH}/%.$(OBJEXT))
PGMS = $(rtems_C_FILES:rtems/%.c=$(ARCH)/%$(LIB_VARIANT).rel)
PGMS += $(sapi_C_FILES:sapi/%.c=$(ARCH)/%$(LIB_VARIANT).rel)
-${ARCH}/%.o: sapi/%.c
+${ARCH}/%.$(OBJEXT): sapi/%.c
test -d $(ARCH) || mkdir $(ARCH)
${COMPILE} -o $@ -c $<
-${ARCH}/%.o: rtems/%.c
+${ARCH}/%.$(OBJEXT): rtems/%.c
test -d $(ARCH) || mkdir $(ARCH)
${COMPILE} -o $@ -c $<