summaryrefslogtreecommitdiffstats
path: root/c/src/optman/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-12-11 06:37:47 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-12-11 06:37:47 +0000
commit595c4bc230ef6ade3f93d9d85c71748416c8c1c9 (patch)
tree19cd57d988c31c720c088ce26bd37fcbcff34b39 /c/src/optman/Makefile.am
parent2002-12-10 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-595c4bc230ef6ade3f93d9d85c71748416c8c1c9.tar.bz2
2002-12-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Use .$(OBJEXT) instead of .o.
Diffstat (limited to 'c/src/optman/Makefile.am')
-rw-r--r--c/src/optman/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/c/src/optman/Makefile.am b/c/src/optman/Makefile.am
index 3a40a6b6db..df38993204 100644
--- a/c/src/optman/Makefile.am
+++ b/c/src/optman/Makefile.am
@@ -18,11 +18,11 @@ C_O_FILES += $(rtems_C_FILES:rtems/%.c=${ARCH}/%.$(OBJEXT))
PGMS = $(rtems_C_FILES:rtems/%.c=$(ARCH)/%$(LIB_VARIANT).rel)
PGMS += $(sapi_C_FILES:sapi/%.c=$(ARCH)/%$(LIB_VARIANT).rel)
-${ARCH}/%.o: sapi/%.c
+${ARCH}/%.$(OBJEXT): sapi/%.c
test -d $(ARCH) || mkdir $(ARCH)
${COMPILE} -o $@ -c $<
-${ARCH}/%.o: rtems/%.c
+${ARCH}/%.$(OBJEXT): rtems/%.c
test -d $(ARCH) || mkdir $(ARCH)
${COMPILE} -o $@ -c $<