summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/mpc505/ictrl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libcpu/powerpc/mpc505/ictrl/Makefile.am')
-rw-r--r--c/src/lib/libcpu/powerpc/mpc505/ictrl/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/powerpc/mpc505/ictrl/Makefile.am b/c/src/lib/libcpu/powerpc/mpc505/ictrl/Makefile.am
new file mode 100644
index 0000000000..2c60b11cc9
--- /dev/null
+++ b/c/src/lib/libcpu/powerpc/mpc505/ictrl/Makefile.am
@@ -0,0 +1,39 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+PGM = $(ARCH)/ictrl.rel
+
+C_FILES = ictrl.c
+
+H_FILES = ictrl.h
+
+ictrl_rel_OBJECTS = $(C_FILES:%.c=$(ARCH)/%.o)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../automake/lib.am
+
+$(PROJECT_INCLUDE):
+ $(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(PGM): $(ictrl_rel_OBJECTS)
+ $(make-rel)
+
+TMPINSTALL_FILES += $(PROJECT_INCLUDE) $(PROJECT_INCLUDE)/ictrl.h
+
+all-local: $(ARCH) $(ictrl_rel_OBJECTS) $(PGM) $(TMPINSTALL_FILES)
+
+.PRECIOUS: $(PGM)
+
+EXTRA_DIST = ictrl.c ictrl.h
+
+include $(top_srcdir)/../../../../../automake/local.am