summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/mpc505/ictrl/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-10-18 18:33:47 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-10-18 18:33:47 +0000
commitf2442183383a7ad70f2a6bc5e8f25e200fa0f54a (patch)
tree3c8ffe7a34dd86363dca28e7f7b810badf65b5ef /c/src/lib/libcpu/powerpc/mpc505/ictrl/Makefile.am
parent2000-10-18 Sergei Organov <osv@javad.ru> (diff)
downloadrtems-f2442183383a7ad70f2a6bc5e8f25e200fa0f54a.tar.bz2
2000-10-18 Sergei Organov <osv@javad.ru>
* Added full support for MPC505. * mpc505/ictrl: New directory. * configure.in, mpc505/Makefile.am: Modified to reflect ictrl addition. * mpc505/ictrl/.cvsignore, mpc505/ictrl/Makefile.am, mpc505/ictrl/ictrl.c, mpc505/ictrl/ictrl.h: New files. * mpc505/timer/timer.c: Use <rtems.h>, not "rtems.h". * mpc505/vectors/Makefile.am: alignment exception handler now included. * mpc505/vectors/vectors.S: Now use constants for exception numbers. * old_exception_processing/ppc_offs.h: New file. * old_exception_processing/Makefile.am: Account for ppc_offs.h. * old_exception_processing/cpu.h: Make Nest and Disable levels volatile. * old_exception_processing/cpu_asm.S: Offsets moved to ppc_offs.h.
Diffstat (limited to 'c/src/lib/libcpu/powerpc/mpc505/ictrl/Makefile.am')
-rw-r--r--c/src/lib/libcpu/powerpc/mpc505/ictrl/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/powerpc/mpc505/ictrl/Makefile.am b/c/src/lib/libcpu/powerpc/mpc505/ictrl/Makefile.am
new file mode 100644
index 0000000000..2c60b11cc9
--- /dev/null
+++ b/c/src/lib/libcpu/powerpc/mpc505/ictrl/Makefile.am
@@ -0,0 +1,39 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+PGM = $(ARCH)/ictrl.rel
+
+C_FILES = ictrl.c
+
+H_FILES = ictrl.h
+
+ictrl_rel_OBJECTS = $(C_FILES:%.c=$(ARCH)/%.o)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../automake/lib.am
+
+$(PROJECT_INCLUDE):
+ $(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(PGM): $(ictrl_rel_OBJECTS)
+ $(make-rel)
+
+TMPINSTALL_FILES += $(PROJECT_INCLUDE) $(PROJECT_INCLUDE)/ictrl.h
+
+all-local: $(ARCH) $(ictrl_rel_OBJECTS) $(PGM) $(TMPINSTALL_FILES)
+
+.PRECIOUS: $(PGM)
+
+EXTRA_DIST = ictrl.c ictrl.h
+
+include $(top_srcdir)/../../../../../automake/local.am