summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/mips/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libcpu/mips/Makefile.am')
-rw-r--r--c/src/lib/libcpu/mips/Makefile.am14
1 files changed, 0 insertions, 14 deletions
diff --git a/c/src/lib/libcpu/mips/Makefile.am b/c/src/lib/libcpu/mips/Makefile.am
index 2630fc29d7..84dc521fac 100644
--- a/c/src/lib/libcpu/mips/Makefile.am
+++ b/c/src/lib/libcpu/mips/Makefile.am
@@ -7,10 +7,6 @@ EXTRA_DIST =
noinst_PROGRAMS =
## cache
-include_libcpudir = $(includedir)/libcpu
-
-include_libcpu_HEADERS =
-
noinst_PROGRAMS += shared/cache.rel
shared_cache_rel_SOURCES = shared/cache/cache.c \
../shared/src/cache_manager.c shared/cache/cache_.h
@@ -36,15 +32,10 @@ shared_interrupts_rel_SOURCES = shared/interrupts/installisrentries.c \
shared/interrupts/isr_entries.S shared/interrupts/isr_entries.h
shared_interrupts_rel_CPPFLAGS = $(AM_CPPFLAGS) $(interrupts_CPPFLAGS)
shared_interrupts_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-include_libcpu_HEADERS += shared/interrupts/isr_entries.h
-
if tx39
-include_libcpu_HEADERS += tx39/include/tx3904.h
endif
if tx49
-include_libcpu_HEADERS += tx49/include/tx4925.h tx49/include/tx4938.h
-
noinst_PROGRAMS += tx49/timer.rel
tx49_timer_rel_SOURCES = timer/timer.c timer/gettime.S
tx49_timer_rel_CPPFLAGS = $(AM_CPPFLAGS)
@@ -52,18 +43,13 @@ tx49_timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
endif
if au1x00
-include_libcpu_HEADERS += au1x00/include/au1x00.h
-
endif
if rm52xx
-include_libcpu_HEADERS += rm52xx/include/rm5231.h
-
noinst_PROGRAMS += rm52xx/timer.rel
rm52xx_timer_rel_SOURCES = timer/timer.c timer/gettime.S
rm52xx_timer_rel_CPPFLAGS = $(AM_CPPFLAGS)
rm52xx_timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
endif
-include $(srcdir)/preinstall.am
include $(top_srcdir)/../../../automake/local.am