summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/i960/i960ca/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libcpu/i960/i960ca/Makefile.am')
-rw-r--r--c/src/lib/libcpu/i960/i960ca/Makefile.am25
1 files changed, 16 insertions, 9 deletions
diff --git a/c/src/lib/libcpu/i960/i960ca/Makefile.am b/c/src/lib/libcpu/i960/i960ca/Makefile.am
index e7aaa471ad..60de75db0c 100644
--- a/c/src/lib/libcpu/i960/i960ca/Makefile.am
+++ b/c/src/lib/libcpu/i960/i960ca/Makefile.am
@@ -5,17 +5,24 @@
include $(top_srcdir)/../../../automake/compile.am
include $(top_srcdir)/../../../automake/lib.am
-C_FILES = cpu_install_intr_stack.c cpu_install_raw_isr.c
-OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-
-#
-# (OPTIONAL) Add local stuff here using +=
-#
+EXTRA_PROGRAMS =
+CLEANFILES =
+noinst_DATA =
if i960ca
-all-local: $(OBJS)
-endif
+EXTRA_PROGRAMS += score.rel
+CLEANFILES += score.rel
+score_rel_SOURCES = cpu_install_intr_stack.c cpu_install_raw_isr.c
+score_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
+score_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-EXTRA_DIST = cpu_install_intr_stack.c cpu_install_raw_isr.c
+EXTRA_PROGRAMS += score_g.rel
+CLEANFILES += score_g.rel
+score_g_rel_SOURCES = $(score_rel_SOURCES)
+score_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
+score_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+noinst_DATA += score$(LIB_VARIANT).rel
+endif
include $(top_srcdir)/../../../automake/local.am