summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/i960/i960ca/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-21 07:18:35 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-21 07:18:35 +0000
commita44c5db9689bf7aced3cd3a476811db1917f1518 (patch)
treeaf47c0bdf7eee74e5fc839c36b05078fc56ffe66 /c/src/lib/libcpu/i960/i960ca/Makefile.am
parent2004-01-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-a44c5db9689bf7aced3cd3a476811db1917f1518.tar.bz2
2004-01-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* i960ca/Makefile.am, i960ka/Makefile.am, i960rp/Makefile.am: Use automake compilation rules. * Makefile.am: Add PREINSTALL_DIRS. * configure.ac: Add subdir-objects to AUTOMAKE_OPTIONS. Require automake >= 1.8.2.
Diffstat (limited to 'c/src/lib/libcpu/i960/i960ca/Makefile.am')
-rw-r--r--c/src/lib/libcpu/i960/i960ca/Makefile.am25
1 files changed, 16 insertions, 9 deletions
diff --git a/c/src/lib/libcpu/i960/i960ca/Makefile.am b/c/src/lib/libcpu/i960/i960ca/Makefile.am
index e7aaa471ad..60de75db0c 100644
--- a/c/src/lib/libcpu/i960/i960ca/Makefile.am
+++ b/c/src/lib/libcpu/i960/i960ca/Makefile.am
@@ -5,17 +5,24 @@
include $(top_srcdir)/../../../automake/compile.am
include $(top_srcdir)/../../../automake/lib.am
-C_FILES = cpu_install_intr_stack.c cpu_install_raw_isr.c
-OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-
-#
-# (OPTIONAL) Add local stuff here using +=
-#
+EXTRA_PROGRAMS =
+CLEANFILES =
+noinst_DATA =
if i960ca
-all-local: $(OBJS)
-endif
+EXTRA_PROGRAMS += score.rel
+CLEANFILES += score.rel
+score_rel_SOURCES = cpu_install_intr_stack.c cpu_install_raw_isr.c
+score_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
+score_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-EXTRA_DIST = cpu_install_intr_stack.c cpu_install_raw_isr.c
+EXTRA_PROGRAMS += score_g.rel
+CLEANFILES += score_g.rel
+score_g_rel_SOURCES = $(score_rel_SOURCES)
+score_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
+score_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+noinst_DATA += score$(LIB_VARIANT).rel
+endif
include $(top_srcdir)/../../../automake/local.am