summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/simsh4/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/sh/simsh4/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/simsh4/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/sh/simsh4/Makefile.am b/c/src/lib/libbsp/sh/simsh4/Makefile.am
index 21c42f9537..6a110c8156 100644
--- a/c/src/lib/libbsp/sh/simsh4/Makefile.am
+++ b/c/src/lib/libbsp/sh/simsh4/Makefile.am
@@ -4,21 +4,30 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
+include $(top_srcdir)/../../../../automake/compile.am
+include $(top_srcdir)/../../bsp.am
+
## wrapup is the one that actually builds and installs the library
## from the individual .rel files built in other directories
-SUBDIRS = . start startup console clock timer wrapup
+SUBDIRS = . startup console clock timer wrapup
SUBDIRS += tools
# FIXME: This directory is missing
# ramdisk
-include $(top_srcdir)/../../bsp.am
-
include_HEADERS += include/syscall.h
include_HEADERS += include/ramdisk.h
include_HEADERS += include/coverhd.h
-all-local: $(PREINSTALL_FILES)
+S_FILES = start/start.S
+$(ARCH)/%$(LIB_VARIANT).$(OBJEXT): start/start.S $(ARCH)/$(dirstamp)
+ ${CCASCOMPILE} -DASM -o $@ -c $<
+
+project_lib_DATA = $(ARCH)/start$(LIB_VARIANT).$(OBJEXT)
+
+all-local: $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
+
+EXTRA_DIST = $(S_FILES)
$(PROJECT_INCLUDE)/syscall.h: include/syscall.h $(PROJECT_INCLUDE)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/syscall.h