summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/simsh4/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-05 07:17:01 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-05 07:17:01 +0000
commit7a5a3a413008919f019200b50577b4df1b1fd194 (patch)
tree0b46fe503010e02b77b0c2880666f736e2b82688 /c/src/lib/libbsp/sh/simsh4/Makefile.am
parent2004-01-05 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-7a5a3a413008919f019200b50577b4df1b1fd194.tar.bz2
2004-01-05 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* start/Makefile.am: Remove. * Makefile.am: Merge-in start/Makefile.am. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/sh/simsh4/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/simsh4/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/sh/simsh4/Makefile.am b/c/src/lib/libbsp/sh/simsh4/Makefile.am
index 21c42f9537..6a110c8156 100644
--- a/c/src/lib/libbsp/sh/simsh4/Makefile.am
+++ b/c/src/lib/libbsp/sh/simsh4/Makefile.am
@@ -4,21 +4,30 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
+include $(top_srcdir)/../../../../automake/compile.am
+include $(top_srcdir)/../../bsp.am
+
## wrapup is the one that actually builds and installs the library
## from the individual .rel files built in other directories
-SUBDIRS = . start startup console clock timer wrapup
+SUBDIRS = . startup console clock timer wrapup
SUBDIRS += tools
# FIXME: This directory is missing
# ramdisk
-include $(top_srcdir)/../../bsp.am
-
include_HEADERS += include/syscall.h
include_HEADERS += include/ramdisk.h
include_HEADERS += include/coverhd.h
-all-local: $(PREINSTALL_FILES)
+S_FILES = start/start.S
+$(ARCH)/%$(LIB_VARIANT).$(OBJEXT): start/start.S $(ARCH)/$(dirstamp)
+ ${CCASCOMPILE} -DASM -o $@ -c $<
+
+project_lib_DATA = $(ARCH)/start$(LIB_VARIANT).$(OBJEXT)
+
+all-local: $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
+
+EXTRA_DIST = $(S_FILES)
$(PROJECT_INCLUDE)/syscall.h: include/syscall.h $(PROJECT_INCLUDE)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/syscall.h