summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/or32/orp/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libbsp/or32/orp/configure.ac')
-rw-r--r--c/src/lib/libbsp/or32/orp/configure.ac42
1 files changed, 42 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/or32/orp/configure.ac b/c/src/lib/libbsp/or32/orp/configure.ac
new file mode 100644
index 0000000000..f5808aa9f4
--- /dev/null
+++ b/c/src/lib/libbsp/or32/orp/configure.ac
@@ -0,0 +1,42 @@
+## Process this file with autoconf to produce a configure script.
+##
+## $Id$
+
+AC_PREREQ(2.52)
+AC_INIT([rtems-c-src-lib-libbsp-arm-armulator],[_RTEMS_VERSION],[rtems-bugs@OARcorp.com])
+AC_CONFIG_SRCDIR([bsp_specs])
+RTEMS_TOP(../../../../../..)
+AC_CONFIG_AUX_DIR(../../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+AM_INIT_AUTOMAKE([no-define foreign 1.6])
+RTEMS_BSP_CONFIGURE
+
+RTEMS_PROG_CC_FOR_TARGET([-ansi -fasm])
+RTEMS_CANONICALIZE_TOOLS
+
+# From newlib
+# Select which debug protocol is being used.
+# ARM_RDP_MONITOR selects the Demon monitor.
+# ARM_RDI_MONITOR selects the Angel monitor.
+# If neither are defined, then hard coded defaults will be used
+# to create the program's environment.
+
+RTEMS_BSPOPTS_SET([ARM_RDI_MONITOR],[*],[1])
+RTEMS_BSPOPTS_HELP([ARM_RDI_MONITOR],
+[If defined enable Angel monitor support])
+
+RTEMS_BSPOPTS_SET([ARM_RDP_MONITOR],[*],[])
+RTEMS_BSPOPTS_HELP([ARM_RDP_MONITOR],
+[If defined enable Demon monitor support])
+
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile
+clock/Makefile
+console/Makefile
+include/Makefile
+start/Makefile
+startup/Makefile
+timer/Makefile
+wrapup/Makefile])
+AC_OUTPUT