summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/or32/orp/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-08-06 13:57:03 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-08-06 13:57:03 +0000
commita24d946fc0e2420a93cc80fe3965d617251df2ba (patch)
tree0b63e2efb981b29ef0d3e009c0f9f9c532e3e0dd /c/src/lib/libbsp/or32/orp/configure.ac
parent2002-08-06 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-a24d946fc0e2420a93cc80fe3965d617251df2ba.tar.bz2
2002-08-06 Chris Ziomkowski <chris@asics.ws>
* .cvsignore, Makefile.am, README, bsp_specs, configure.ac, times, clock/.cvsignore, clock/Makefile.am, clock/clockdrv.c, console/.cvsignore, console/Makefile.am, console/console.c, console/console.h, include/.cvsignore, include/Makefile.am, include/bsp.h, start/.cvsignore, start/Makefile.am, start/start.S, startup/.cvsignore, startup/bspclean.c, startup/bspstart.c, startup/linkcmds, startup/main.c, startup/setvec.c, timer/.cvsignore, timer/Makefile.am, timer/timer.c, timer/timerisr.c, wrapup/.cvsignore, wrapup/Makefile.am, ChangeLog: New files added as part of merge from OpenCores repository.
Diffstat (limited to 'c/src/lib/libbsp/or32/orp/configure.ac')
-rw-r--r--c/src/lib/libbsp/or32/orp/configure.ac42
1 files changed, 42 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/or32/orp/configure.ac b/c/src/lib/libbsp/or32/orp/configure.ac
new file mode 100644
index 0000000000..f5808aa9f4
--- /dev/null
+++ b/c/src/lib/libbsp/or32/orp/configure.ac
@@ -0,0 +1,42 @@
+## Process this file with autoconf to produce a configure script.
+##
+## $Id$
+
+AC_PREREQ(2.52)
+AC_INIT([rtems-c-src-lib-libbsp-arm-armulator],[_RTEMS_VERSION],[rtems-bugs@OARcorp.com])
+AC_CONFIG_SRCDIR([bsp_specs])
+RTEMS_TOP(../../../../../..)
+AC_CONFIG_AUX_DIR(../../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+AM_INIT_AUTOMAKE([no-define foreign 1.6])
+RTEMS_BSP_CONFIGURE
+
+RTEMS_PROG_CC_FOR_TARGET([-ansi -fasm])
+RTEMS_CANONICALIZE_TOOLS
+
+# From newlib
+# Select which debug protocol is being used.
+# ARM_RDP_MONITOR selects the Demon monitor.
+# ARM_RDI_MONITOR selects the Angel monitor.
+# If neither are defined, then hard coded defaults will be used
+# to create the program's environment.
+
+RTEMS_BSPOPTS_SET([ARM_RDI_MONITOR],[*],[1])
+RTEMS_BSPOPTS_HELP([ARM_RDI_MONITOR],
+[If defined enable Angel monitor support])
+
+RTEMS_BSPOPTS_SET([ARM_RDP_MONITOR],[*],[])
+RTEMS_BSPOPTS_HELP([ARM_RDP_MONITOR],
+[If defined enable Demon monitor support])
+
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile
+clock/Makefile
+console/Makefile
+include/Makefile
+start/Makefile
+startup/Makefile
+timer/Makefile
+wrapup/Makefile])
+AC_OUTPUT