summaryrefslogtreecommitdiffstats
path: root/c/src/exec/itron/macros/rtems/itron/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/itron/macros/rtems/itron/Makefile.am')
-rw-r--r--c/src/exec/itron/macros/rtems/itron/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/c/src/exec/itron/macros/rtems/itron/Makefile.am b/c/src/exec/itron/macros/rtems/itron/Makefile.am
new file mode 100644
index 0000000000..45bee17d6f
--- /dev/null
+++ b/c/src/exec/itron/macros/rtems/itron/Makefile.am
@@ -0,0 +1,25 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+if MACROS
+I_FILES = eventflags.inl fmempool.inl intr.inl mbox.inl msgbuffer.inl \
+ network.inl port.inl semaphore.inl sysmgmt.inl task.inl time.inl \
+ vmempool.inl
+
+noinst_HEADERS = $(I_FILES)
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/itron \
+ $(I_FILES:%=$(PROJECT_INCLUDE)/rtems/itron/%)
+
+$(PROJECT_INCLUDE)/rtems/itron:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/rtems/itron/%.inl: %.inl
+ $(INSTALL_DATA) $< $@
+endif
+
+all-local: $(PREINSTALL_FILES)
+
+include $(top_srcdir)/../../../../automake/local.am