summaryrefslogtreecommitdiffstats
path: root/c/src/exec/itron/macros/rtems/itron/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-12-01 19:00:04 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-12-01 19:00:04 +0000
commit7afbca071bcc0b76d20f2a11dc7521503e952e31 (patch)
tree3a924810539a8345e05d9911ecb59a657fa4f99a /c/src/exec/itron/macros/rtems/itron/Makefile.am
parent2000-12-01 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-7afbca071bcc0b76d20f2a11dc7521503e952e31.tar.bz2
2000-12-01 Joel Sherrill <joel@OARcorp.com>
* Added macro support to ITRON API. This is known to compile. * Makefile.am: Added macros directory. * configure.in: Removed error check for enabling macros. * macros/.cvsignore, macros/Makefile.am, macros/rtems/.cvsignore, macros/rtems/Makefile.am, macros/rtems/itron/.cvsignore, macros/rtems/itron/Makefile.am, macros/rtems/itron/eventflags.inl, macros/rtems/itron/fmempool.inl, macros/rtems/itron/intr.inl, macros/rtems/itron/mbox.inl, macros/rtems/itron/msgbuffer.inl, macros/rtems/itron/network.inl, macros/rtems/itron/port.inl, macros/rtems/itron/semaphore.inl, macros/rtems/itron/sysmgmt.inl, macros/rtems/itron/task.inl, macros/rtems/itron/time.inl, macros/rtems/itron/vmempool.inl: New files.
Diffstat (limited to 'c/src/exec/itron/macros/rtems/itron/Makefile.am')
-rw-r--r--c/src/exec/itron/macros/rtems/itron/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/c/src/exec/itron/macros/rtems/itron/Makefile.am b/c/src/exec/itron/macros/rtems/itron/Makefile.am
new file mode 100644
index 0000000000..45bee17d6f
--- /dev/null
+++ b/c/src/exec/itron/macros/rtems/itron/Makefile.am
@@ -0,0 +1,25 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+if MACROS
+I_FILES = eventflags.inl fmempool.inl intr.inl mbox.inl msgbuffer.inl \
+ network.inl port.inl semaphore.inl sysmgmt.inl task.inl time.inl \
+ vmempool.inl
+
+noinst_HEADERS = $(I_FILES)
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/itron \
+ $(I_FILES:%=$(PROJECT_INCLUDE)/rtems/itron/%)
+
+$(PROJECT_INCLUDE)/rtems/itron:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/rtems/itron/%.inl: %.inl
+ $(INSTALL_DATA) $< $@
+endif
+
+all-local: $(PREINSTALL_FILES)
+
+include $(top_srcdir)/../../../../automake/local.am