summaryrefslogtreecommitdiffstats
path: root/c/src/exec/itron/inline/rtems/itron/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/itron/inline/rtems/itron/Makefile.am')
-rw-r--r--c/src/exec/itron/inline/rtems/itron/Makefile.am14
1 files changed, 6 insertions, 8 deletions
diff --git a/c/src/exec/itron/inline/rtems/itron/Makefile.am b/c/src/exec/itron/inline/rtems/itron/Makefile.am
index 659227b218..f5368fff77 100644
--- a/c/src/exec/itron/inline/rtems/itron/Makefile.am
+++ b/c/src/exec/itron/inline/rtems/itron/Makefile.am
@@ -3,16 +3,16 @@
##
AUTOMAKE_OPTIONS = foreign 1.4
+
if INLINE
I_FILES = eventflags.inl fmempool.inl intr.inl mbox.inl msgbuffer.inl \
- network.inl port.inl semaphore.inl sysmgmt.inl task.inl \
- time.inl vmempool.inl
+ network.inl port.inl semaphore.inl sysmgmt.inl task.inl time.inl \
+ vmempool.inl
noinst_HEADERS = $(I_FILES)
-PREINSTALL_FILES = \
-$(PROJECT_INCLUDE)/rtems/itron \
-$(I_FILES:%=$(PROJECT_INCLUDE)/rtems/itron/%)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/itron \
+ $(I_FILES:%=$(PROJECT_INCLUDE)/rtems/itron/%)
$(PROJECT_INCLUDE)/rtems/itron:
@$(mkinstalldirs) $@
@@ -20,8 +20,6 @@ $(PROJECT_INCLUDE)/rtems/itron/%.inl: %.inl
$(INSTALL_DATA) $< $@
endif
-all-am: $(PREINSTALL_FILES)
-debug-am: $(PREINSTALL_FILES)
-profile-am: $(PREINSTALL_FILES)
+all-local: $(PREINSTALL_FILES)
include $(top_srcdir)/../../../../automake/local.am