summaryrefslogtreecommitdiffstats
path: root/c/src/exec/itron/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/exec/itron/configure.in')
-rw-r--r--c/src/exec/itron/configure.in13
1 files changed, 3 insertions, 10 deletions
diff --git a/c/src/exec/itron/configure.in b/c/src/exec/itron/configure.in
index 8f789378e5..a568520ef1 100644
--- a/c/src/exec/itron/configure.in
+++ b/c/src/exec/itron/configure.in
@@ -30,10 +30,6 @@ RTEMS_CHECK_ITRON_API(RTEMS_BSP)
# If RTEMS macros are enabled, then use them. Otherwise, use inlines.
if test "$RTEMS_USE_MACROS" = "yes"; then
INLINEdir="macros"
- if test "$HAS_ITRON_API" = "yes"; then
- # The problem is that there is currently no code in itron/macros :)
- AC_MSG_ERROR(Macros are not implemented for the ITRON API)
- fi
else
INLINEdir="inline"
fi
@@ -43,12 +39,6 @@ AM_CONDITIONAL(MACROS,test "$INLINEdir" = "macros" )
## Needed when using automake for libs/rels
RTEMS_CHECK_NEWLIB
-# If RTEMS macros are enabled, then use them. Otherwise, refuse to build
-if test "$RTEMS_USE_MACROS" = "yes"; then
-# The problem is that there is currently no code in itron/macros :)
-AC_MSG_ERROR(Macros are not implemented for the ITRON API)
-fi
-
##
## FIXME: We configure and build the macros subdirectory, too.
## Should probably use AM_CONDITIONALs to disable them in future
@@ -63,5 +53,8 @@ include/rtems/itron/Makefile
inline/Makefile
inline/rtems/Makefile
inline/rtems/itron/Makefile
+macros/Makefile
+macros/rtems/Makefile
+macros/rtems/itron/Makefile
)