summaryrefslogtreecommitdiffstats
path: root/c/src/exec/itron/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-12-01 19:00:04 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-12-01 19:00:04 +0000
commit7afbca071bcc0b76d20f2a11dc7521503e952e31 (patch)
tree3a924810539a8345e05d9911ecb59a657fa4f99a /c/src/exec/itron/configure.in
parent2000-12-01 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-7afbca071bcc0b76d20f2a11dc7521503e952e31.tar.bz2
2000-12-01 Joel Sherrill <joel@OARcorp.com>
* Added macro support to ITRON API. This is known to compile. * Makefile.am: Added macros directory. * configure.in: Removed error check for enabling macros. * macros/.cvsignore, macros/Makefile.am, macros/rtems/.cvsignore, macros/rtems/Makefile.am, macros/rtems/itron/.cvsignore, macros/rtems/itron/Makefile.am, macros/rtems/itron/eventflags.inl, macros/rtems/itron/fmempool.inl, macros/rtems/itron/intr.inl, macros/rtems/itron/mbox.inl, macros/rtems/itron/msgbuffer.inl, macros/rtems/itron/network.inl, macros/rtems/itron/port.inl, macros/rtems/itron/semaphore.inl, macros/rtems/itron/sysmgmt.inl, macros/rtems/itron/task.inl, macros/rtems/itron/time.inl, macros/rtems/itron/vmempool.inl: New files.
Diffstat (limited to 'c/src/exec/itron/configure.in')
-rw-r--r--c/src/exec/itron/configure.in13
1 files changed, 3 insertions, 10 deletions
diff --git a/c/src/exec/itron/configure.in b/c/src/exec/itron/configure.in
index 8f789378e5..a568520ef1 100644
--- a/c/src/exec/itron/configure.in
+++ b/c/src/exec/itron/configure.in
@@ -30,10 +30,6 @@ RTEMS_CHECK_ITRON_API(RTEMS_BSP)
# If RTEMS macros are enabled, then use them. Otherwise, use inlines.
if test "$RTEMS_USE_MACROS" = "yes"; then
INLINEdir="macros"
- if test "$HAS_ITRON_API" = "yes"; then
- # The problem is that there is currently no code in itron/macros :)
- AC_MSG_ERROR(Macros are not implemented for the ITRON API)
- fi
else
INLINEdir="inline"
fi
@@ -43,12 +39,6 @@ AM_CONDITIONAL(MACROS,test "$INLINEdir" = "macros" )
## Needed when using automake for libs/rels
RTEMS_CHECK_NEWLIB
-# If RTEMS macros are enabled, then use them. Otherwise, refuse to build
-if test "$RTEMS_USE_MACROS" = "yes"; then
-# The problem is that there is currently no code in itron/macros :)
-AC_MSG_ERROR(Macros are not implemented for the ITRON API)
-fi
-
##
## FIXME: We configure and build the macros subdirectory, too.
## Should probably use AM_CONDITIONALs to disable them in future
@@ -63,5 +53,8 @@ include/rtems/itron/Makefile
inline/Makefile
inline/rtems/Makefile
inline/rtems/itron/Makefile
+macros/Makefile
+macros/rtems/Makefile
+macros/rtems/itron/Makefile
)