summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxconcurrency01/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel@rtems.org>2016-02-19 16:00:48 -0600
committerJoel Sherrill <joel@rtems.org>2016-04-14 16:28:10 -0500
commit8228548d127dd73439615f45f38f92b8a42bcfed (patch)
treeb7a48c833e30bcbd736f649815129c8aff2201f4 /testsuites/psxtests/psxconcurrency01/Makefile.am
parentposix: Run key destructors during thread restart (diff)
downloadrtems-8228548d127dd73439615f45f38f92b8a42bcfed.tar.bz2
Add pthread_getconcurrency() and pthread_setconcurrency()
This is the very simple implementation specified by the Open Group for implementations with 1:1 kernel thread to user thread mappings. http://pubs.opengroup.org/onlinepubs/9699919799/functions/pthread_getconcurrency.html updates #2680.
Diffstat (limited to 'testsuites/psxtests/psxconcurrency01/Makefile.am')
-rw-r--r--testsuites/psxtests/psxconcurrency01/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/testsuites/psxtests/psxconcurrency01/Makefile.am b/testsuites/psxtests/psxconcurrency01/Makefile.am
new file mode 100644
index 0000000000..2be4ebb989
--- /dev/null
+++ b/testsuites/psxtests/psxconcurrency01/Makefile.am
@@ -0,0 +1,23 @@
+
+rtems_tests_PROGRAMS = psxconcurrency01
+psxconcurrency01_SOURCES = init.c ../include/pmacros.h
+
+dist_rtems_tests_DATA = psxconcurrency01.scn
+dist_rtems_tests_DATA += psxconcurrency01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxconcurrency01_OBJECTS)
+LINK_LIBS = $(psxconcurrency01_LDLIBS)
+
+psxconcurrency01$(EXEEXT): $(psxconcurrency01_OBJECTS) $(psxconcurrency01_DEPENDENCIES)
+ @rm -f psxconcurrency01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am