summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxconcurrency01/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuites/psxtests/psxconcurrency01/Makefile.am')
-rw-r--r--testsuites/psxtests/psxconcurrency01/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/testsuites/psxtests/psxconcurrency01/Makefile.am b/testsuites/psxtests/psxconcurrency01/Makefile.am
new file mode 100644
index 0000000000..2be4ebb989
--- /dev/null
+++ b/testsuites/psxtests/psxconcurrency01/Makefile.am
@@ -0,0 +1,23 @@
+
+rtems_tests_PROGRAMS = psxconcurrency01
+psxconcurrency01_SOURCES = init.c ../include/pmacros.h
+
+dist_rtems_tests_DATA = psxconcurrency01.scn
+dist_rtems_tests_DATA += psxconcurrency01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxconcurrency01_OBJECTS)
+LINK_LIBS = $(psxconcurrency01_LDLIBS)
+
+psxconcurrency01$(EXEEXT): $(psxconcurrency01_OBJECTS) $(psxconcurrency01_DEPENDENCIES)
+ @rm -f psxconcurrency01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am