summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/Makefile.am
diff options
context:
space:
mode:
authorVaibhav Gupta <vaibhavgupta40@gmail.com>2019-08-14 03:33:02 +0530
committerJoel Sherrill <joel@rtems.org>2019-09-10 13:47:29 -0500
commit5e5867a32ac6c98e8397903556af078de39b8544 (patch)
tree7b5328e1e69c941f40399220a249f9354962a66f /testsuites/psxtests/Makefile.am
parentrtems: Make rtems_version_control_key() safer (diff)
downloadrtems-5e5867a32ac6c98e8397903556af078de39b8544.tar.bz2
Add psxfenv01 test to psxtests
Note that this test requires a functional fenv implementation. Some targets have multilib variants where the fenv implementation is not 100% passing.
Diffstat (limited to 'testsuites/psxtests/Makefile.am')
-rwxr-xr-xtestsuites/psxtests/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/testsuites/psxtests/Makefile.am b/testsuites/psxtests/Makefile.am
index c12b03636d..2ccb10a473 100755
--- a/testsuites/psxtests/Makefile.am
+++ b/testsuites/psxtests/Makefile.am
@@ -415,6 +415,18 @@ psxfchx01_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_psxfchx01) \
$(support_includes) -I$(top_srcdir)/include
endif
+if HAS_FENV
+if TEST_psxfenv01
+psx_tests += psxfenv01
+psx_screens += psxfenv01/psxfenv01.scn
+psx_docs += psxfenv01/psxfenv01.doc
+psxfenv01_SOURCES = psxfenv01/init.c
+psxfenv01_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_psxfenv01) \
+ $(support_includes)
+psxfenv01_LDADD = -lm $(LDADD)
+endif
+endif
+
if TEST_psxfile01
psx_tests += psxfile01
psx_screens += psxfile01/psxfile01.scn