summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@oarcorp.com>2014-07-23 15:35:35 -0500
committerJoel Sherrill <joel.sherrill@oarcorp.com>2014-07-23 16:53:24 -0500
commit875fff0ae3d7676bbd8816caf1b32e33142d2e73 (patch)
treede7a2c0e7f8dcdef75aac8a9e913de873aa097b6 /cpukit/score/Makefile.am
parentadjtime.c: Use timestamp math and simplify (diff)
downloadrtems-875fff0ae3d7676bbd8816caf1b32e33142d2e73.tar.bz2
Add _TOD_Adjust to SCORE TOD Handler.
This lays the proper structure for doing future work on time adjustment algorithms. Any TOD adjustments should be requested at the API level and performed at the SCORE level. Additionally updated a test.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index 431dade665..55e10e9c4c 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -319,8 +319,8 @@ libscore_a_SOURCES += src/ts64addto.c src/ts64dividebyinteger.c \
## TOD_C_FILES
libscore_a_SOURCES += src/coretod.c src/coretodset.c src/coretodget.c \
src/coretodgetuptimetimespec.c src/coretodtickle.c \
- src/coretodsecondssinceepoch.c \
- src/coretodtickspersec.c
+ src/coretodsecondssinceepoch.c src/coretodtickspersec.c \
+ src/coretodadjust.c
## WATCHDOG_C_FILES
libscore_a_SOURCES += src/watchdog.c src/watchdogadjust.c \