summaryrefslogtreecommitdiffstats
path: root/cpukit/libmisc/shell/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-05-24 21:58:39 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-05-24 21:58:39 +0000
commitb2712e35b948d7ab37cf6ef46bcdfea678506444 (patch)
treee7575dbae5f5861131ac9cf03cdea1bfc7447269 /cpukit/libmisc/shell/Makefile.am
parent2000-05-24 Fernando Ruiz Casas <fernando.ruiz@ctv.es> (diff)
downloadrtems-b2712e35b948d7ab37cf6ef46bcdfea678506444.tar.bz2
2000-05-24 Fernando Ruiz Casas <fernando.ruiz@ctv.es>
* monitor/mon-prmisc.c: Correct print line. * shell/Makefile.am: Added new file telnetd.c. * shell/telnetd.c, shell/telnetd.h, shell/pty.c: New files. * shell/shell.c, shell/cmds.c, shell/shell.h: Numerous improvments: - The shell_init has a new parameter 'forever' because in /dev/console you need that this process runs forever but in tcp/ip not. (respawn?) - A new task for every session opened trought tcp/ip telnet client. (the chargen,daytime and more are possible of implementation but I ask me if they are necesary) - Exit from the session delete the task and when the client fails too. - More cmds have been implemented. (very reduced version of these) umask, chmod, id, whoami, rm, cat, ... - A reduced line edit has been implemented. Ctrl-C abort the input, Ctrl-d in the first position gives EOF (logout). '\b' and DEL makes the rubout operation. I think that readline() for every session spents a lot of resources.
Diffstat (limited to 'cpukit/libmisc/shell/Makefile.am')
-rw-r--r--cpukit/libmisc/shell/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/cpukit/libmisc/shell/Makefile.am b/cpukit/libmisc/shell/Makefile.am
index 814cf40c44..94e5350c82 100644
--- a/cpukit/libmisc/shell/Makefile.am
+++ b/cpukit/libmisc/shell/Makefile.am
@@ -9,10 +9,10 @@ include_rtemsdir = $(includedir)/rtems
LIBNAME = libshell-tmp
LIB = $(ARCH)/$(LIBNAME).a
-C_FILES = cmds.c shell.c
+C_FILES = cmds.c shell.c pty.c telnetd.c
C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
-include_rtems_HEADERS = shell.h
+include_rtems_HEADERS = shell.h telnetd.h
OBJS = $(C_O_FILES)
@@ -39,6 +39,6 @@ all-local: $(ARCH) $(PREINSTALL_FILES) $(OBJS) $(LIB)
.PRECIOUS: $(LIB)
-EXTRA_DIST = README shell.c cmds.c shell.h
+EXTRA_DIST = README shell.c cmds.c pty.c telnetd.c shell.h telnetd.h
include $(top_srcdir)/../../../automake/local.am