summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2012-11-04 21:04:39 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2012-11-22 16:35:07 +0100
commitf1738ed619ed01199535410887a81c6ac99e482c (patch)
tree2578ed634fd96ffc933ec3470e2d06ff82cd8e5a /cpukit/configure.ac
parentscore: Inline _API_extensions_Run_postswitch() (diff)
downloadrtems-f1738ed619ed01199535410887a81c6ac99e482c.tar.bz2
score: PR1607: Add and use CPU_SIZEOF_POINTER
Add and use new CPU port define CPU_SIZEOF_POINTER. It must be an integer literal that can be used by the assembler. This value will be used to calculate offsets of structure members. These offsets will be used in assembler code. The size of a pointer is part of the application binary interface (ABI) and thus independent of the actual programming language. The compiler will provide defines to determine the current ABI. We use these defines to select the appropriate CPU_SIZEOF_POINTER value. Static assertions in the new file "cpukit/score/src/percpuasm.c" will ensure that the value of CPU_SIZEOF_POINTER is consistent with the current compiler settings. Also the offset values used by assembler code are verfied.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac9
1 files changed, 0 insertions, 9 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index d0d957d723..e3c4dd4d1e 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -154,10 +154,6 @@ rtems_major=`echo _RTEMS_VERSION | sed "s/\..*//"`
rtems_minor=`echo _RTEMS_VERSION | sed "s/[[0-9]][[0-9]]*\.//;s/\..*//"`
rtems_revision=`echo _RTEMS_VERSION | sed "s/[[0-9]][[0-9]]*\.//;s/[[0-9]][[0-9]]*\.//;s/\..*//"`
-## This is needed to generate the field offsets of the per CPU
-## data structure so they can be accessed from assembly code.
-AC_CHECK_SIZEOF([void *])
-
_RTEMS_CPUOPT_INIT
RTEMS_CPUOPT([RTEMS_DEBUG],
@@ -233,11 +229,6 @@ RTEMS_CPUOPT([__RTEMS_ADA__],
## Then we propagate a private copy of the value into cpuopts.h
## so it is always available to the RTEMS header files.
-RTEMS_CPUOPT([__RTEMS_SIZEOF_VOID_P__],
- [true],
- [$ac_cv_sizeof_void_p],
- [Size of a void * pointer])
-
RTEMS_CPUOPT([__RTEMS_MAJOR__],
[true],
[$rtems_major],