summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac9
1 files changed, 0 insertions, 9 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index d0d957d723..e3c4dd4d1e 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -154,10 +154,6 @@ rtems_major=`echo _RTEMS_VERSION | sed "s/\..*//"`
rtems_minor=`echo _RTEMS_VERSION | sed "s/[[0-9]][[0-9]]*\.//;s/\..*//"`
rtems_revision=`echo _RTEMS_VERSION | sed "s/[[0-9]][[0-9]]*\.//;s/[[0-9]][[0-9]]*\.//;s/\..*//"`
-## This is needed to generate the field offsets of the per CPU
-## data structure so they can be accessed from assembly code.
-AC_CHECK_SIZEOF([void *])
-
_RTEMS_CPUOPT_INIT
RTEMS_CPUOPT([RTEMS_DEBUG],
@@ -233,11 +229,6 @@ RTEMS_CPUOPT([__RTEMS_ADA__],
## Then we propagate a private copy of the value into cpuopts.h
## so it is always available to the RTEMS header files.
-RTEMS_CPUOPT([__RTEMS_SIZEOF_VOID_P__],
- [true],
- [$ac_cv_sizeof_void_p],
- [Size of a void * pointer])
-
RTEMS_CPUOPT([__RTEMS_MAJOR__],
[true],
[$rtems_major],