summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2010-04-12 06:36:35 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2010-04-12 06:36:35 +0000
commit84221cb9228172d7c2efaad6a1a51d21af28328b (patch)
treec37417b0b07132e293ba516e79fb80b5fc925bbd /cpukit/configure.ac
parent2010-04-12 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-84221cb9228172d7c2efaad6a1a51d21af28328b.tar.bz2
2010-04-12 Ralf Corsépius <ralf.corsepius@rtems.org>
* configure.ac: Check for sched.h.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index df9fd0cedd..8ad530ccff 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -66,7 +66,7 @@ AC_CHECK_FUNCS([ttyname getcwd])
# </FIXME>
## Check if the installed toolchain has these headers
-AC_CHECK_HEADERS([tar.h errno.h])
+AC_CHECK_HEADERS([tar.h errno.h sched.h])
## error out if libc doesn't provide stdint.h
AS_IF([test x"${ac_cv_header_stdint_h}" != xyes],
@@ -80,6 +80,10 @@ AS_IF([test x"${ac_cv_header_inttypes_h}" != xyes],
AS_IF([test x"${ac_cv_header_errno_h}" != xyes],
[AC_MSG_ERROR([Required header errno.h not found])])
+## error out if libc doesn't provide sched.h
+AS_IF([test x"${ac_cv_header_sched_h}" != xyes],
+[AC_MSG_ERROR([Required header sched.h not found])])
+
AC_HEADER_STDBOOL
AS_IF([test x"${ac_cv_header_stdbool_h}" != xyes],
[AC_MSG_ERROR([No sufficient stdbool.h found])])