summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2010-04-12 06:31:21 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2010-04-12 06:31:21 +0000
commitda0475f5332cffa5c09d73d4fbd56531c1eb909c (patch)
tree6c7b0a4149b8fccff03e251221d06a20adae9800 /cpukit/configure.ac
parent2010-04-12 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-da0475f5332cffa5c09d73d4fbd56531c1eb909c.tar.bz2
2010-04-12 Ralf Corsépius <ralf.corsepius@rtems.org>
* configure.ac: Check for WORD_BIT, LONG_BIT.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index d5b1cd2378..df9fd0cedd 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -242,6 +242,10 @@ AC_CHECK_HEADERS([sys/queue.h],[NEED_SYS_QUEUE_H=no],[NEED_SYS_QUEUE_H=yes])
# configuration-time diagnostics and are not really used.
AC_CHECK_DECLS([_POSIX_LOGIN_NAME_MAX],,,[#include <limits.h>])
AC_CHECK_DECLS([CHAR_BIT],,,[#include <limits.h>])
+# FIXME: Mandatory in SUSv4, optional in SUSv3.
+# Not implemented in GCC/newlib, so far.
+AC_CHECK_DECLS([WORD_BIT],,,[#include <limits.h>])
+AC_CHECK_DECLS([LONG_BIT],,,[#include <limits.h>])
## BSD-ism, excluded from POSIX, but available on most platforms
AC_CHECK_DECLS([sbrk],,,[#include <unistd.h>])