summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-02-26 19:23:53 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-02-26 19:23:53 +0000
commit58d38a0c763e77bfb45be76bfb04727ed5f5526c (patch)
tree57209e748ba86a263405f14e6459800221b48ccc /cpukit/configure.ac
parent2008-02-26 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-58d38a0c763e77bfb45be76bfb04727ed5f5526c.tar.bz2
2008-02-26 Joel Sherrill <joel.sherrill@OARcorp.com>
* configure.ac, libfs/Makefile.am: Add nfsclient to cpukit. Although the use of RPC/XDR could be an issue, the code does build multilib across all targets. There are a few remaining warnings to deal with. * libfs/src/nfsclient/.cvsignore, libfs/src/nfsclient/ChangeLog.slac, libfs/src/nfsclient/LICENSE, libfs/src/nfsclient/Makefile.am, libfs/src/nfsclient/README, libfs/src/nfsclient/preinstall.am, libfs/src/nfsclient/rfc1094.txt, libfs/src/nfsclient/proto/mount_prot.h, libfs/src/nfsclient/proto/mount_prot.x, libfs/src/nfsclient/proto/mount_prot_xdr.c, libfs/src/nfsclient/proto/nfs_prot.h, libfs/src/nfsclient/proto/nfs_prot.x, libfs/src/nfsclient/proto/nfs_prot_xdr.c, libfs/src/nfsclient/src/cexphelp.c, libfs/src/nfsclient/src/dirutils.c, libfs/src/nfsclient/src/librtemsNfs.h, libfs/src/nfsclient/src/nfs.c, libfs/src/nfsclient/src/nfs.modini.c, libfs/src/nfsclient/src/nfsTest.c, libfs/src/nfsclient/src/rpcio.c, libfs/src/nfsclient/src/rpcio.h, libfs/src/nfsclient/src/rpcio.modini.c, libfs/src/nfsclient/src/sock_mbuf.c, libfs/src/nfsclient/src/xdr_mbuf.c: New files.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index ab955de261..e827cf3406 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -332,6 +332,12 @@ test x"${RTEMS_CPU}" != x"unix" \
AC_CONFIG_HEADER(config.h)
+## These are needed by the NFS Client
+AC_CHECK_PROG(RPCGEN,rpcgen,rpcgen)
+AM_CONDITIONAL([RPCTOOLS],[test "$RPCGEN" = rpcgen \
+&& test -n "$AWK" \
+&& test "$enable_rpcgen" = yes])
+
RTEMS_AMPOLISH3
# Explicitly list all Makefiles here
@@ -360,6 +366,7 @@ posix/Makefile
itron/Makefile
libblock/Makefile
libfs/Makefile
+libfs/src/nfsclient/Makefile
libgnat/Makefile
libcsupport/Makefile
libnetworking/Makefile