summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2013-10-31 15:00:20 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2013-11-04 15:22:48 +0100
commit8cb28826ffaccd2f9f9f0c77c9cfdf61d1100069 (patch)
treef326b81959591559c91e843326ec198a8d3f9949 /cpukit/Makefile.am
parentFilesystem: Add poll() handler (diff)
downloadrtems-8cb28826ffaccd2f9f9f0c77c9cfdf61d1100069.tar.bz2
Filesystem: Add kernel event filter handler
This handler is necessary to implement the KQUEUE(2) system calls. Add <sys/event.h> from FreeBSD 8.4.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 8a20242eb9..3d8360774f 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -50,6 +50,7 @@ include_HEADERS += libmd/md4.h
include_HEADERS += libmd/md5.h
include_sys_HEADERS += libcsupport/include/sys/ioccom.h
+include_sys_HEADERS += libcsupport/include/sys/event.h
include_sys_HEADERS += libcsupport/include/sys/filio.h
include_sys_HEADERS += libcsupport/include/sys/ioctl.h
include_sys_HEADERS += libcsupport/include/sys/poll.h