summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2013-10-31 15:00:14 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2013-11-04 15:22:47 +0100
commit16829460572c9d8451154b2c296ac1abb7701b78 (patch)
treec92fd3fed60437b55a04f7d7e451dd636ec44da5 /cpukit/Makefile.am
parentbsp/realview-pbx-a9: Add NULL pointer protection (diff)
downloadrtems-16829460572c9d8451154b2c296ac1abb7701b78.tar.bz2
Filesystem: Add poll() handler
This handler is necessary to implement the SELECT(2) and POLL(2) system calls. Add <sys/poll.h> from FreeBSD 8.4.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 7bc62960e2..8a20242eb9 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -52,6 +52,7 @@ include_HEADERS += libmd/md5.h
include_sys_HEADERS += libcsupport/include/sys/ioccom.h
include_sys_HEADERS += libcsupport/include/sys/filio.h
include_sys_HEADERS += libcsupport/include/sys/ioctl.h
+include_sys_HEADERS += libcsupport/include/sys/poll.h
include_sys_HEADERS += libcsupport/include/sys/statvfs.h
include_sys_HEADERS += libcsupport/include/sys/sockio.h
include_sys_HEADERS += libcsupport/include/sys/ttycom.h