summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2019-12-16 14:50:59 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2020-02-12 09:08:37 +0100
commit61357479894b08c9017ba39f90572c57dc307869 (patch)
tree3be2b2696a480dd5ffef351663a0ca944e26bbfd /cpukit/Makefile.am
parentscore: Split up objects allocation (diff)
downloadrtems-61357479894b08c9017ba39f90572c57dc307869.tar.bz2
score: Split up objects free
Split up the different objects free methods into separate functions. This helps to avoid a dependency on the workspace in case no objects or a static set of objects is configured. Update #3835.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 25dbd58813..86a406e6dd 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -864,6 +864,7 @@ librtemscpu_a_SOURCES += score/src/objectallocateunlimited.c
librtemscpu_a_SOURCES += score/src/objectclose.c
librtemscpu_a_SOURCES += score/src/objectextendinformation.c
librtemscpu_a_SOURCES += score/src/objectfree.c
+librtemscpu_a_SOURCES += score/src/objectfreestatic.c
librtemscpu_a_SOURCES += score/src/objectgetnext.c
librtemscpu_a_SOURCES += score/src/objectinitializeinformation.c
librtemscpu_a_SOURCES += score/src/objectnametoid.c