summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2019-12-10 10:41:48 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2020-02-12 09:08:37 +0100
commit24851567c38f573e9176529e9ca431fbf80c6cef (patch)
treebd75506122c9a310228d1c58fba7544a5e05dd65 /cpukit/Makefile.am
parentscore: Add _Objects_Free_objects_block() (diff)
downloadrtems-24851567c38f573e9176529e9ca431fbf80c6cef.tar.bz2
score: Split up objects allocation
Split up the different objects allocation methods into separate functions. This helps to avoid a dependency on the workspace in case no objects or a static set of objects is configured. Change license to BSD-2-Clause according to file histories. Update #3053. Update #3835.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 06e98c31ff..25dbd58813 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -858,6 +858,9 @@ librtemscpu_a_SOURCES += score/src/memoryfill.c
librtemscpu_a_SOURCES += score/src/memoryzerobeforeuse.c
librtemscpu_a_SOURCES += score/src/memoryzerofreeareas.c
librtemscpu_a_SOURCES += score/src/objectallocate.c
+librtemscpu_a_SOURCES += score/src/objectallocatenone.c
+librtemscpu_a_SOURCES += score/src/objectallocatestatic.c
+librtemscpu_a_SOURCES += score/src/objectallocateunlimited.c
librtemscpu_a_SOURCES += score/src/objectclose.c
librtemscpu_a_SOURCES += score/src/objectextendinformation.c
librtemscpu_a_SOURCES += score/src/objectfree.c