summaryrefslogtreecommitdiffstats
path: root/c/src/wrapup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-07-03 20:16:01 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-07-03 20:16:01 +0000
commit2984cf1bc7f5f4174c069f72826f0f304966ac3a (patch)
treed7aef0653a1a310f697bd8df8789f349ae8b0aae /c/src/wrapup/Makefile.am
parent2002-07-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-2984cf1bc7f5f4174c069f72826f0f304966ac3a.tar.bz2
2002-07-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: explicitly create $(ARCH) when building $(LIB). Add bsplib_DATA = $(LIB).
Diffstat (limited to 'c/src/wrapup/Makefile.am')
-rw-r--r--c/src/wrapup/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/c/src/wrapup/Makefile.am b/c/src/wrapup/Makefile.am
index d0f4a97b08..edc5ce81fa 100644
--- a/c/src/wrapup/Makefile.am
+++ b/c/src/wrapup/Makefile.am
@@ -39,6 +39,7 @@ all-local: $(ARCH) $(TMPINSTALL_FILES)
$(LIB): $(SRCS)
rm -f $@
rm -rf $(ARCH)/*
+ test -d $(ARCH) || mkdir $(ARCH)
for f in $(SRCS); do \
case $$f in \
*.o | *.rel) \
@@ -66,4 +67,7 @@ $(LIB): $(SRCS)
rm -f $(ARCH)/*
$(RANLIB) $@
+bsplibdir = $(libdir)/@RTEMS_BSP@/lib
+bsplib_DATA = $(LIB)
+
include $(top_srcdir)/../../../automake/local.am