summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-10-20 13:33:28 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-10-20 13:33:28 +0000
commit623ffdb1555b66935ef4b0624ec7953134fd2f26 (patch)
tree5c77cc33ee675aceb9d6e5c00352c19964a6417c /c/src/lib/libcpu/powerpc/configure.in
parent2000-10-20 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-623ffdb1555b66935ef4b0624ec7953134fd2f26.tar.bz2
2000-10-20 Joel Sherrill <joel@OARcorp.com>
* configure.in, Makefile.am: Explicitly specify whether an RTEMS_CPU_MODEL is using old or new exception processing. This is important because when building multilib, you do not know the RTEMS_CPU_MODEL. So everything built in a multilib'ed RTEMS must be independent of the exception model and allow for late binding to the exception code.
Diffstat (limited to 'c/src/lib/libcpu/powerpc/configure.in')
-rw-r--r--c/src/lib/libcpu/powerpc/configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/powerpc/configure.in b/c/src/lib/libcpu/powerpc/configure.in
index d4ed2d415b..61cfc36089 100644
--- a/c/src/lib/libcpu/powerpc/configure.in
+++ b/c/src/lib/libcpu/powerpc/configure.in
@@ -34,10 +34,22 @@ AM_CONDITIONAL(shared, test "$RTEMS_CPU_MODEL" = "mpc750" \
|| test "$RTEMS_CPU_MODEL" = "mpc860" \
|| test "$RTEMS_CPU_MODEL" = "mpc8xx" )
+## there are no 601 or 602 BSPs currently. The 505 BSPs are in user land.
AM_CONDITIONAL(new_exception_processing, \
test "$RTEMS_CPU_MODEL" = "mpc750" || \
test "$RTEMS_CPU_MODEL" = "mpc604")
+## The goal is to get rid of the old exception processing code but
+## but all BSPs in the distribution must be migrated to the new model
+## first.
+AM_CONDITIONAL(old_exception_processing, \
+test "$RTEMS_CPU_MODEL" = "ppc403" || \
+test "$RTEMS_CPU_MODEL" = "mpc505" || \
+test "$RTEMS_CPU_MODEL" = "ppc603e" || \
+test "$RTEMS_CPU_MODEL" = "mpc8xx" \
+)
+
+## test on CPU type
AM_CONDITIONAL(mpc505, test "$RTEMS_CPU_MODEL" = "mpc505")
AM_CONDITIONAL(mpc6xx, test "$RTEMS_CPU_MODEL" = "mpc6xx" \
|| test "$RTEMS_CPU_MODEL" = "mpc604" \