summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'c/src/lib/libcpu/powerpc/configure.in')
-rw-r--r--c/src/lib/libcpu/powerpc/configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/powerpc/configure.in b/c/src/lib/libcpu/powerpc/configure.in
index d4ed2d415b..61cfc36089 100644
--- a/c/src/lib/libcpu/powerpc/configure.in
+++ b/c/src/lib/libcpu/powerpc/configure.in
@@ -34,10 +34,22 @@ AM_CONDITIONAL(shared, test "$RTEMS_CPU_MODEL" = "mpc750" \
|| test "$RTEMS_CPU_MODEL" = "mpc860" \
|| test "$RTEMS_CPU_MODEL" = "mpc8xx" )
+## there are no 601 or 602 BSPs currently. The 505 BSPs are in user land.
AM_CONDITIONAL(new_exception_processing, \
test "$RTEMS_CPU_MODEL" = "mpc750" || \
test "$RTEMS_CPU_MODEL" = "mpc604")
+## The goal is to get rid of the old exception processing code but
+## but all BSPs in the distribution must be migrated to the new model
+## first.
+AM_CONDITIONAL(old_exception_processing, \
+test "$RTEMS_CPU_MODEL" = "ppc403" || \
+test "$RTEMS_CPU_MODEL" = "mpc505" || \
+test "$RTEMS_CPU_MODEL" = "ppc603e" || \
+test "$RTEMS_CPU_MODEL" = "mpc8xx" \
+)
+
+## test on CPU type
AM_CONDITIONAL(mpc505, test "$RTEMS_CPU_MODEL" = "mpc505")
AM_CONDITIONAL(mpc6xx, test "$RTEMS_CPU_MODEL" = "mpc6xx" \
|| test "$RTEMS_CPU_MODEL" = "mpc604" \