summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/Makefile.am
diff options
context:
space:
mode:
authorThomas Doerfler <Thomas.Doerfler@embedded-brains.de>2007-07-10 16:00:28 +0000
committerThomas Doerfler <Thomas.Doerfler@embedded-brains.de>2007-07-10 16:00:28 +0000
commitf610e83f5350e09d29a23352b420551d06f15499 (patch)
tree6f1914643c458af3c680a057405dea6bd0c7400a /c/src/lib/libcpu/powerpc/Makefile.am
parent2007-07-06 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-f610e83f5350e09d29a23352b420551d06f15499.tar.bz2
compilable release of virtex/gen83xx/gen5200 powerpc adaptations. Merged many different versions of new exception handling code to shared sources.
Diffstat (limited to 'c/src/lib/libcpu/powerpc/Makefile.am')
-rw-r--r--c/src/lib/libcpu/powerpc/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/powerpc/Makefile.am b/c/src/lib/libcpu/powerpc/Makefile.am
index 5a230bf54f..388a8aae86 100644
--- a/c/src/lib/libcpu/powerpc/Makefile.am
+++ b/c/src/lib/libcpu/powerpc/Makefile.am
@@ -324,5 +324,17 @@ mpc8260_timer_rel_CPPFLAGS = $(AM_CPPFLAGS)
mpc8260_timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
endif
+if mpc83xx
+include_mpc83xxdir = $(includedir)/mpc83xx
+include_mpc83xx_HEADERS = mpc83xx/include/mpc83xx.h
+include_mpc83xx_HEADERS += mpc83xx/network/tsec.h
+## mpc83xx/network
+noinst_PROGRAMS += mpc83xx/tsec.rel
+mpc83xx_tsec_rel_SOURCES = mpc83xx/network/tsec.c
+mpc83xx_tsec_rel_CPPFLAGS = $(AM_CPPFLAGS)
+mpc83xx_tsec_rel_CPPFLAGS += -D__INSIDE_RTEMS_BSD_TCPIP_STACK__ -D__BSD_VISIBLE
+mpc83xx_tsec_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+endif
+
include $(srcdir)/preinstall.am
include $(top_srcdir)/../../../automake/local.am