summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/Makefile.am
diff options
context:
space:
mode:
authorThomas Doerfler <Thomas.Doerfler@embedded-brains.de>2008-07-14 08:46:06 +0000
committerThomas Doerfler <Thomas.Doerfler@embedded-brains.de>2008-07-14 08:46:06 +0000
commit3c6fe2e7f95f6bff53123df9377b114cadeac874 (patch)
treefef9ad7a4cd45497a1a84c1b7f9cd103eb258c43 /c/src/lib/libcpu/powerpc/Makefile.am
parentcorrections in display driver (diff)
downloadrtems-3c6fe2e7f95f6bff53123df9377b114cadeac874.tar.bz2
added haleakala BSP contributed by Michael Hamel
Diffstat (limited to 'c/src/lib/libcpu/powerpc/Makefile.am')
-rw-r--r--c/src/lib/libcpu/powerpc/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/c/src/lib/libcpu/powerpc/Makefile.am b/c/src/lib/libcpu/powerpc/Makefile.am
index 8a071a2dd9..6c75b46a83 100644
--- a/c/src/lib/libcpu/powerpc/Makefile.am
+++ b/c/src/lib/libcpu/powerpc/Makefile.am
@@ -126,8 +126,19 @@ ppc403_tty_drv_rel_CPPFLAGS = $(AM_CPPFLAGS)
ppc403_tty_drv_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
endif
-endif
+endif # ppc403
+
+if ppc405
+
+## ppc4xx/include
+include_ppc4xxdir = $(includedir)/ppc4xx
+include_ppc4xx_HEADERS = ppc403/include/ppc405gp.h \
+ ppc403/include/ppc405ex.h
+endif # ppc405
+
+
+## mpc5xx
EXTRA_DIST += mpc5xx/README
if mpc5xx
include_mpc5xxdir = $(includedir)/mpc5xx
@@ -341,6 +352,7 @@ mpc8260_timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
endif
if mpc83xx
+
include_mpc83xxdir = $(includedir)/mpc83xx
include_mpc83xx_HEADERS = mpc83xx/include/mpc83xx.h
include_mpc83xx_HEADERS += mpc83xx/network/tsec.h