summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/shsim/scitab/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-29 10:35:45 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-29 10:35:45 +0000
commita9285f5b0df4e2923f288afce96baed2f81f06af (patch)
tree70f0c170fa5ed8b5ab8a341880a7b9f1e96f96fb /c/src/lib/libbsp/sh/shsim/scitab/Makefile.am
parent2004-01-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-a9285f5b0df4e2923f288afce96baed2f81f06af.tar.bz2
2004-01-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in clock/Makefile.am, gdbsci/Makefile.am, startup/Makefile.am, wrapup/Makefile.am, console/Makefile.am, scitab/Makefile.am, trap34/Makefile.am. Use automake compilation rules. * clock/Makefile.am, gdbsci/Makefile.am, startup/Makefile.am, wrapup/Makefile.am, console/Makefile.am, scitab/Makefile.am, trap34/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/sh/shsim/scitab/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/shsim/scitab/Makefile.am33
1 files changed, 0 insertions, 33 deletions
diff --git a/c/src/lib/libbsp/sh/shsim/scitab/Makefile.am b/c/src/lib/libbsp/sh/shsim/scitab/Makefile.am
deleted file mode 100644
index c42125de77..0000000000
--- a/c/src/lib/libbsp/sh/shsim/scitab/Makefile.am
+++ /dev/null
@@ -1,33 +0,0 @@
-##
-## $Id$
-##
-
-PGM = $(ARCH)/scitab.rel
-
-C_FILES = scitab.c
-C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-
-OBJS = $(C_O_FILES)
-
-include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../../../automake/lib.am
-
-SHGEN = $(PROJECT_TOPdir)/tools/cpu/sh/shgen
-
-#
-# (OPTIONAL) Add local stuff here using +=
-#
-
-CLEANFILES = scitab.c
-
-$(PGM): $(OBJS)
- $(make-rel)
-
-scitab.c: $(SHGEN)
- $(SHGEN) -H @CPU_CLOCK_RATE_HZ@ sci > $@
-
-all-local: $(OBJS) $(PGM)
-
-.PRECIOUS: $(PGM)
-
-include $(top_srcdir)/../../../../automake/local.am