summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/bfin/TLL6527M/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2011-04-20 20:23:39 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2011-04-20 20:23:39 +0000
commitad65fc7fb7eb05af2df8ef0639653ef46c88788c (patch)
tree3669658647739567f01bfcb4eaff9b6f78b0f8e7 /c/src/lib/libbsp/bfin/TLL6527M/Makefile.am
parent2011-04-20 Rohan Kangralkar <rkangral@ece.neu.edu> (diff)
downloadrtems-ad65fc7fb7eb05af2df8ef0639653ef46c88788c.tar.bz2
2011-04-20 Rohan Kangralkar <rkangral@ece.neu.edu>
PR 1781/bsps * ChangeLog, Makefile.am, README, bsp_specs, configure.ac, preinstall.am, times, console/console.c, include/bsp.h, include/cplb.h, include/tm27.h, make/custom/TLL6527M.cfg, startup/bspstart.c, startup/linkcmds: New files. Initial port for the TLL6527Mboard that contains blackfin 52X range of processors. Used eZKit533 as a reference for building the port.
Diffstat (limited to 'c/src/lib/libbsp/bfin/TLL6527M/Makefile.am')
-rw-r--r--c/src/lib/libbsp/bfin/TLL6527M/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/bfin/TLL6527M/Makefile.am b/c/src/lib/libbsp/bfin/TLL6527M/Makefile.am
new file mode 100644
index 0000000000..6b15ad1077
--- /dev/null
+++ b/c/src/lib/libbsp/bfin/TLL6527M/Makefile.am
@@ -0,0 +1,52 @@
+##
+## $Id$
+##
+
+ACLOCAL_AMFLAGS = -I ../../../../aclocal
+
+include $(top_srcdir)/../../../../automake/compile.am
+
+include_bspdir = $(includedir)/bsp
+
+dist_project_lib_DATA = bsp_specs
+
+include_HEADERS = include/bsp.h
+include_HEADERS += include/tm27.h
+include_HEADERS += include/cplb.h
+
+nodist_include_HEADERS = include/bspopts.h
+nodist_include_bsp_HEADERS = ../../shared/include/bootcard.h
+DISTCLEANFILES = include/bspopts.h
+
+noinst_PROGRAMS =
+
+include_HEADERS += ../../shared/include/coverhd.h
+
+noinst_LIBRARIES = libbspstart.a
+libbspstart_a_SOURCES = ../shared/start/start.S
+project_lib_DATA = start.$(OBJEXT)
+
+dist_project_lib_DATA += startup/linkcmds
+
+noinst_LIBRARIES += libbsp.a
+
+libbsp_a_SOURCES = ../../shared/bsplibc.c ../../shared/bsppost.c \
+ ../../shared/bsppredriverhook.c startup/bspstart.c \
+ ../../shared/bspclean.c ../../shared/sbrk.c ../../shared/setvec.c \
+ ../../shared/bootcard.c ../../shared/gnatinstallhandler.c \
+ ../../shared/bspgetworkarea.c
+
+libbsp_a_SOURCES += console/console.c
+
+libbsp_a_LIBADD = ../../../libcpu/@RTEMS_CPU@/mmu.rel
+libbsp_a_LIBADD += ../../../libcpu/@RTEMS_CPU@/@RTEMS_CPU_MODEL@/interrupt.rel
+libbsp_a_LIBADD += ../../../libcpu/@RTEMS_CPU@/cache.rel
+libbsp_a_LIBADD += ../../../libcpu/@RTEMS_CPU@/uart.rel
+libbsp_a_LIBADD += ../../../libcpu/@RTEMS_CPU@/clock.rel
+libbsp_a_LIBADD += ../../../libcpu/@RTEMS_CPU@/rtc.rel
+libbsp_a_LIBADD += ../../../libcpu/@RTEMS_CPU@/timer.rel
+
+EXTRA_DIST = times
+
+include $(srcdir)/preinstall.am
+include $(top_srcdir)/../../../../automake/local.am