summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/beagle/Makefile.am
diff options
context:
space:
mode:
authorPunit Vara <punitvara@gmail.com>2016-07-04 15:05:43 -0300
committerMartin Galvan <martin.galvan@tallertechnologies.com>2016-07-04 15:09:06 -0300
commit5e3096db5a1d766ece4068fbfe625c8a3db31b23 (patch)
treeba4c87be0e05ac62e5474a3ccb0d2412ce965ffe /c/src/lib/libbsp/arm/beagle/Makefile.am
parentBeaglebone: Add original BBBIO PWM driver (diff)
downloadrtems-5e3096db5a1d766ece4068fbfe625c8a3db31b23.tar.bz2
Beaglebone: Update PWM driver imported from BBBIO
This patch adapts the previously added Beaglebone PWM code from BBBIO to RTEMS. This work was done in the context of the Google Summer of Code 2016, and further patches will follow to improve the code quality and documentation.
Diffstat (limited to 'c/src/lib/libbsp/arm/beagle/Makefile.am')
-rw-r--r--c/src/lib/libbsp/arm/beagle/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/arm/beagle/Makefile.am b/c/src/lib/libbsp/arm/beagle/Makefile.am
index 904cb8454b..aa28f365f8 100644
--- a/c/src/lib/libbsp/arm/beagle/Makefile.am
+++ b/c/src/lib/libbsp/arm/beagle/Makefile.am
@@ -41,6 +41,7 @@ include_bsp_HEADERS += include/irq.h
include_bsp_HEADERS += include/i2c.h
include_bsp_HEADERS += include/beagleboneblack.h
include_bsp_HEADERS += include/bbb-gpio.h
+include_bsp_HEADERS += include/bbb-pwm.h
include_libcpu_HEADERS =
include_libcpu_HEADERS += ../../../libcpu/arm/shared/include/arm-cp15.h
@@ -117,6 +118,9 @@ libbsp_a_SOURCES += misc/i2c.c
# GPIO
libbsp_a_SOURCES += gpio/bbb-gpio.c
+#pwm
+libbsp_a_SOURCES += pwm/pwm.c
+
#RTC
libbsp_a_SOURCES += rtc.c
libbsp_a_SOURCES += ../../shared/tod.c